Building Geometrical Constructions in CubeCAD

From Emagtech Wiki
Jump to: navigation, search
Splash-cad.jpg

An Intuitive 3D Parametric CAD Modeler Shared By All EM.Cube Computational Modules

Cube-icon.png Fdtd-ico.png Prop-ico.png Po-ico.png Static-ico.png Planar-ico.png Metal-ico.png

Back icon.png Back to EM.Cube Main Page

CubeCAD in a Nutshell

CubeCAD is a comprehensive, parametric, 3D CAD modeler along with integrated mesh generation, data processing and visualization capabilities and a powerful Python scripting environment. A highly streamlined visual interface literally puts all of CubeCAD's features at your fingertips. With the click of buttons, you can build complex 3D models and structures in seconds using a large variety of intuitive mouse-based object creation and transformation tools. Import and export of standard CAD formats allow for native construction of complex geometries along with the ability to fly in external CAD models with utmost ease. CubeCAD also features an extensive library of mathematical functions that can be used for construction of new geometries and data or post-processing of existing data. CubeCAD allows you to visualize simulated, measured or imported 3D data in a variety of formats and overlay them on your CAD structures.

All of EM.Cube's computational modules use CubeCAD together with individually customized navigation trees as their graphical user interface and geometry definition utility. Learning CubeCAD is therefore the stepping stone for learning all the other modules. Once you have mastered the basics of CubeCAD, using the other modules will be very straightforward.

An example of a complex geometric structure in CubeCAD.

CubeCAD Features at a Glance

Geometric Features

  • Native Solids: Box, cylinder, cone, pyramid, sphere, ellipsoid, torus, and polymesh solids (generalized polyhedra)
  • Native Surfaces: Rectangular strip (or loop), circle strip (or ring), radial strip, ellipse strip, spiral strip, triangle strip, taper strip (with exponential transition), regular polygon, polystrip, NURBS strip, polymesh surfaces, equation-based parametric surfaces
  • Native Curves: line, polyline, NURBS curve, circle, super-quadratic curve, parabola, hyperbola, spiral curve, helix, and equation-based Cartesian, polar and parametric curves
  • Easy mouse-based object creation and real-time editing
  • Translate, rotate, scale, mirror and link operations
  • Boolean (union, subtract and intersect) operations and composite objects with access to constituent objects' properties
  • Explode solids into surfaces and surfaces into curves
  • Build 3D arrays of objects with dynamic editing and access to parent objects' properties
  • Extrude, loft or revolve faces/surfaces and edges/curves and edit the parent objects dynamically
  • Skin between multiple faces/surfaces and bridge between multiple edges/curves
  • Discretize solids and surfaces into polymesh objects with regular or structured triangular cells
  • Polygonize surfaces and curves
  • Fit spline curves onto polylines and smooth surfaces onto polymesh surfaces
  • Fillet sharp corners and polylines
  • Sweep curves into strips, pipes or rail curve and surfaces along other curves
  • Fill closed curves to create planar objects
  • Merge or sew curves
  • Roughen surfaces and solids with specified statistics
  • Create random clouds of a given key object within a specified container object
  • Fractal trees with random pruning
  • Adaptive grid with local view rotation
  • Snap to objects, nodes, edges/curves or faces/surfaces
  • Arbitrary work planes for sketching

Parametric Modeling

  • Define variables to relate and control geometric object properties
  • Constrained variables with arbitrary mathematical expressions including random variables and Python functions
  • Continuous, discrete or mixed parametric spaces
  • Dynamic update and editing
  • Dry runs for sanity check
  • Object links with arbitrary local offsets and rotation angles

CAD Model Import & Export

  • STEP import/export
  • IGES import/export
  • STL import/export
  • DEM import
  • Shapefile import
  • DXF import/export
  • FACET file import/export for triangular surface mesh
  • Whole or partial geometry import/export using Python scripts

Data Generation & Processing

  • Spreadsheet view of data with data processing features
  • Import/export of data into spreadsheets
  • Hundreds of mathematical functions for data processing
  • User defined Python functions and scripts
  • Statistical analysis of data
  • Differentiation, integration, discrete Fourier transform and linear regression of data
  • Data generator utility for creation of 3D Cartesian data

Data Visualization

  • 3D complex data surfaces defined over triangular meshes with magnitude, phase and 3D vector plots
  • 2D complex uniform and non-uniform data planes with magnitude, phase and 3D vector plots
  • Vectorial data surfaces and planes with individual X, Y, Z and total plots
  • Extensive graphing capability (Cartesian, polar, Smith chart, bar chart, polar stem chart, etc.) with dynamic editing
An Apache helicopter.
The imported model of the Apache helicopter.

Constructing Physical Structures Using Standard Geometric Objects

The Variety of EM.Cube's Native Object Types

In EM.Cube, objects are generally categorized into four types: solids, surfaces, curves and special objects.

  • Curves are one-dimensional objects, whose length can be measured. The simplest curve object is a (straight) line. Other curve objects include circle, super-quadratic curve, parabola, hyperbola, spiral curve, helix, polyline and NURBS curve. EM.Cube also provides a generalize curve generator.
  • Surfaces are two-dimensional objects whose surface area can be measured. A surface is usually characterized by a number of edges that enclose the object's area. The edges meet at vertices or nodes. The simplest surface object is a rectangle strip, which has four edges and four vertices. Other surface objects include circle strip, radial strip, ellipse strip, taper strip, regular polygon, spiral strip, polystrip and NURBS curve. EM.Cube also provides a generalized surface generator.
  • Solids are three-dimensional objects whose volume can be measured. A solid is usually characterized by a number of faces that enclose the object's volume. Faces meet at edges and edges meet at vertices or nodes. The simplest solid object is a box, which has six faces, twelve edges and eight vertices. Other solid objects include cylinder, cone, pyramid, sphere, ellipsoid and taper. EM.Cube also provides a Platonic solid generator which includes tetrahedron, tessellated hexahedron, octahedron, tessellated dodecahedron and icosahedron.
  • EM.Cube currently offers two special object types: point and fractal tree. A Point is a dimensionless object that is represented by a set of coordinates (X,Y,Z). A fractal tree is a group of recursively scaled self-similar objects.

In view of the drawing process and geometrical properties, objects can also be divided into two groups: dimensional objects and nodal objects. A dimensional object is characterized by a local coordinate system (a center and local X-, Y- and Z-axes) and a number of dimensional parameters such as length, width, height, radius, etc. Examples of dimensional objects are box, sphere, rectangular strip, line, helix, etc. In addition to the standard geometric object types, there are generic curve objects, generic surface objects and generic solid objects. Most external CAD objects are imported as objects of generic type. You can translate or rotate an object of generic type, but you cannot changes its size properties. A nodal object is characterized by a set of points (nodes). EM.Cube's nodal objects include polystrip, polyline, NURBS strip, NURBS curve and polymesh objects.

CubeCAD provides a diverse set of standard geometric objects that are fully parameterized. In addition to the center coordinates and rotation angles, these objects have a variety of dimensional parameters that are used to set and control their size and geometrical shape. More complex objects can be created by editing and combining these basic shapes. Objects can be created by clicking on one of the object buttons on the Object Toolbar or from the Object → Solid, Object → Surface, or Object → Curve menus. Once an object tool is selected, left click anywhere on the work plane to draw the object.

Property dialog of a dimensional triangle strip object.
Property dialog of a nodal polystrip object.

Glossary of Standard Geometric Objects

Info icon.png To learn more about the standard geometric objects, see the Glossary of EM.Cube's Standard Geometric Objects.

Standard Solid Objects Standard Surface Objects Standard Curve Objects
solids planar surfaces CURVES

Local Coordinate System

EM.Cube provides a number of different coordinate systems. The two most important ones are the World Coordinate System (WCS) and the Local Coordinate System (LCS). Every object has a Local Coordinate System that determines the location of the object in the world coordinate system and its orientation, i.e., its rotation angles with respect to the world principal axes. The center of the local coordinate system is the most important characteristic point of an object. The position of the LCS center varies among different object types. For example, the LCS center of a box is the center of its bottom face, while the LCS center of a sphere is its true geometrical center. The LCS has three local X-, Y-, and Z-axes. For most objects, these axes line up with the object's natural axes. For example, the local Z-axis of a cylinder or a cone is always aligned along its geometrical axis. When you draw a new object, its LCS axes are aligned along the principal world axes by default. After you rotate an object, its LCS axes are no longer aligned with the principal world axes.

When you start the EM.Cube application, you will only see the world X- and Y-axes in the Project Workspace. A small trident icon at the lower left corner of the workspace also shows the world coordinate system at all times. There are many instances when the relative orientation of objects with respect to one another and their positive or negative directions are very important. In such cases, making the LCS of objects visible would be very useful. You can enable the local coordinate system of an object by selecting it, right clicking on the surface of the object or right clicking on its name in the Navigation Tree and selecting Show LCS from the contextual menu. This will display the red, green and blue local X-, Y- and Z-axes of the objects in dashed lines. To disable the LCS, select Hide LCS from the contextual menu of that object.

The local Coordinates System (LCS) of Basic Shapes.

Organizing Objects in Color Groups

CubeCAD's Navigation Tree groups and organizes objects using a hierarchical system. Located at the top of the Navigation Tree and under the CubeCAD icon are two main groups: Geometrical Construction and Data Visualization. Under Geometrical Construction, you create or import and manage CAD objects. Under Data Visualization, you create or import and display 3D representations of real, complex, scalar or vector data in a variety of formats. The Data Visualization group and its usage will be discussed later in this manual. The next sections of the manual will present a detailed discussion of CAD objects, their creation, transformation and management.

Geometrical Construction (represented by the Physstruc tn.png icon) contains the Parts that form a structure. Parts (represented by the Layer tn.png icon) contain all the native objects that you draw in CubeCAD's project workspace as well as all the CAD objects that your import from supported external CAD files. Parts are made up of one or more colors. CubeCAD's objects are grouped by Color represented by the Coloricon tn.png icon. You can create many colors and add objects to each color group. All the objects belonging to a Color literally share the same color or texture. When you start EM.Cube for the first time and draw a new object in CubeCAD, a default color named "Color_1" is immediately created to hold your new object. The default color is grey. You can change the name, color or texture of this default group or add new color groups. To create a new Color, right click on the Parts item of the Navigation Tree and select Insert New Color.... A dialog opens up that contains a default name for the new color. Accept the default name or type in a new name for the new color group.

To delete a color group, right click on its name in the Navigation Tree and select the Delete item from the contextual menu. Note that once a color is deleted, all the objects belonging to that color group are also deleted. You can delete all the color groups at once by right clicking on the Parts item of the Navigation Tree and selecting Delete All Colors from the contextual menu.

CubeCAD's Navigation Tree.

Transferring Objects Among Different Groups or Modules

You can move objects from one color to another in CubeCAD. You can also move objects from CubeCAD to other modules or among different modules. To transfer an object from its current color group to another color group, first select it in the Project Workspace and right click on its surface to open the contextual menu. Select Move To from the contextual menu. This menu item opens up to a number of submenus that include CubeCAD and possibly the names of some other EM.Cube modules. Each submenu leads to yet other submenus that contain the names of all the object groups that are available for object transfer. For instance, if CubeCAD has three color groups, color_1, color_2, color_3, you will see submenus like Move To → CubeCAD → Color_1, Color_2 or Color_3.Select the desired object group to transfer the selected object to. The transferred object's name is removed from its original color group and is added to the new color group. The color of the transferred object also changes to that of the new color group. In exactly the same way, you can transfer any object from its current group in any module to any other object group in any other module as long as it is listed in the Move To submenus.

You can also transfer objects from the Navigation Tree. When you import external CAD objects, they are always imported into CubeCAD initially. Then, you have to move them to the right module. In such cases, you can select one of more object names on the Navigation Tree and right click on the highlighted selection to access the Move To submenus in the contextual menu. If you have highlighted a multiple selection using the Ctrl or Shift keys, remember to keep holding those keys down when right clicking; otherwise, you will lose the selection.

Moving objects from their current color group to another color group or to another EM.Cube module.

Creating New Objects

Drawing CAD Objects in the Active Color Group

Only one color group of the navigation tree is active at any time. All the newly drawn objects belong to the active color group. CubeCAD displays the active color's name in bold letters. When you start EM.Cube for the first time and draw a new object in CubeCAD, a default grey color named "Color_1" is immediately created and set as the active color. Every time you create a new color, it is set as the active color. To change the active color, right-click on the name of a color group and select Activate from the contextual menu. New objects will now be added under the new active color.

To draw an object in EM.Cube, click one of the many Object buttons in Object Toolbar and start drawing a new object in the project workspace. Alternatively, you can call on any object creation tool through one of the menu items Object → Solids, Surfaces or Curves submenus. Once an object creation tool is selected, the shape of the cursor changes to a cross, signifying that EM.Cube is in object creation mode. Left-click anywhere in the main window to draw an object of the selected type. While the new object is being drawn, a property dialog appears on the lower right corner of the screen. Also, a small Help Tip window opens up on the upper right corner of the screen that guides you through the drawing process. The property dialog allows you to customize the new object's dimensions and other parameters. The entered values for length parameters are always in the currently selected project units and angles are measured in degrees.

Setting the active color.

The Property Dialog & Object Parameter Types

Each CubeCAD object has a number of properties that are characteristic to the object type and are listed in its Property Dialog. When you draw a new object, its property dialog opens up while you are drawing it. After the new object has been created, its properties dialog remains open until you close it. To open the property dialog of an object, double click on the object's surface in the project workspace or first select it and then right click on its surface and select Properties... from its contextual menu. You can also open an object's property dialog by right-clicking on its name in the navigation tree and selecting Properties... from the contextual menu. The figure below shows the property dialog of a Box object.

A box object's property dialog and its edit handles.

All object property dialogs share some common fields:

  • Object Label
  • Object Linkage information
  • Spatial information such as LCS center coordinates and rotation angles
  • Dimensional properties such as length, width, height, radius, etc. (this applies to dimensional object types like box, rectangle strip, line, etc.)
  • Nodal information such as node indices and coordinates (this applies to nodal object types like polyline, polystrip, etc.)

CAD objects are characterized by their Local Coordinate Systems (LCS). Spatial information contains two sets of information: LCS Center – the X-, Y-, and Z-coordinates of the origin of the local coordinate system, and LCS Rotation – the right-sense rotation angles of the object about the X, Y, and Z-axes before the object is translated to the specified base center. As you will see later, objects in CubeCAD can be linked to each other. The linkage information part of the property dialog shows whether an object is linked to another "parent" object and if so, in what manner. The type and number of property fields differ among the native CubeCAD objects. The box object, for instance, is characterized by X-Size, Y-Size, Z-Size values along with two Fix Center check boxes and two Cap Ends check boxes.

Modifying Objects Using Edit Handles

Once you finish drawing an new object in the default "Draw & Edit" mode or when you open the property dialog of an object, EM.Cube enters its "Object Edit Mode". In this mode, a number of small red balls appear on the object that are called "Edit Handles" and are located at some of the object's snap points The exact number of edit handles varies among the different object types. For example, a box has six edit handles, one at the center of each face. A rectangular strip has four edit handles, one at the midpoint of each edge. A line has two edit handles at its two ends. In the "Object Edit Mode", you can grab an edit handle and drag it with the mouse to change the size or shape of an object. By grabbing we mean first hovering on the handle (mouse-over) to highlight it and then clicking the left mouse and dragging it around. In dimensional objects, grabbing an edit handle usually changes a certain length or an angle. In nodal objects, grabbing an edit handle changes the position of a node.

General Drawing Rules

By default, when you draw a new object, its property dialog appears at the lower right corner of main Window, and EM.Cube's object edit mode is enabled. This means that you can edit the newly drawn object at this time. After the drawing is completed, the mouse cursor changes to its "Normal" arrow shape. Besides the default "Draw & Edit" mode, EM.Cube provides another drawing mode called "Persistent Draw". In this persistent mode, after you complete the drawing of an object, the mouse cursor does not return to "Normal" and stays in the drawing mode. You can continue drawing more objects of the same type as many as you like. Switching the drawing mode is done from the User Preferences Dialog, which can be accessed from Edit Preferences... In the "Drawing Mode" section of the Objects tab of this dialog, select the radio button labeled Persistent Draw. In this mode, you will still see the object's property dialog at the lower left corner of Main Window. You can hide this dialog by unchecking the box labeled Display Properties.

Changing CubeCAD's drawing mode from the preferences dialog.

A number of object types have additional drawing modes, where you can fix their LCS center. These objects are:

  • Box
  • Pyramid
  • Rectangle Strip
  • Ellipse Strip
  • Line
  • Super-Quadratic Curve

Of the above list, box, pyramid, rectangle strip, ellipse strip and super-quadratic curve (i.e. all but line) have fixed centers by default. This means that when you draw these objects or later edit them, the coordinates of their LCS centers remains fixed. As a result, as you draw the base of a box or a pyramid in the XY plane, or as you draw a rectangle strip, an ellipse strip or a super-quadratic curve in the XY plane, the dimensions of the object expand or shrink in equal amounts along the ±X-axis, and so do they along the ±Y-axis. By contrast, the line object doesn't have a fixed center by default. This means that the length of the line object always expands away from or shrinks towards its start point. If you check the Fix Center box in the line's property dialog, then its length will changes in equal amounts from both ends.

Drawing a rectangle strip object without or with a fixed center (locked base).

Except for the line object, you can fix the LCS center of the other object types listed above along the X and Y axes independently. For this purpose, you need to check the boxes labeled Fix Center: X and Fix Center: Y, respectively, in the object's property dialog. When both boxes are checked, it is called a center-based drawing mode. When box boxes are unchecked, it is called a corner-based drawing mode. In this mode, the object tends to expand away from or shrink towards one of its vertices. When only one of the two "Fix Center" boxes is checked, it is called an edge-based drawing mode. In this mode, the object tends to expand away from or shrink towards one of its edges. When you draw one of the above object types (except for line) for the first time, you are in the center-based drawing mode by default. You can use the keyboard shortcut B successively to toggle among the center-, edge- and corner-based drawing modes after the first point has been established.

The center-, edge- and corner-based drawing modes.

Visual Aids & Other Convenient Features for Drawing Objects

Using the Grid & Principal Work Planes

CubeCAD is a full 3D CAD environment that allows you to move your mouse to any arbitrary point in the three-dimensional coordinate space. A work plane is the plane on which the mouse cursor is located and moves freely around. When you start the EM.Cube application, the mouse always moves on the XY plane, meaning that the XY plane is your default work plane. In addition, EM.Cube's "Snap-to-Grid" mode is enabled by default even though the project workspace's grid is not displayed by default. As you move the mouse around, it snaps to the invisible grid points. This provides a convenient way to draw objects with precise dimensions and at precise locations. The coordinates of the current location of the mouse are reported in the Status Bar.

Info icon.png Click here to learn more about EM.Cube's Grid or Grid Properties.

Using the View Toolbar, you can easily change the work plane to any of the three principal coordinate planes:

Xygrid tool tn.png CLICK TO MAKE XY PLANE ACTIVE

When the work plane is set to the XY plane, the Z-coordinate of the mouse is fixed and equal to zero.

Yzgrid tool tn.png CLICK TO MAKE YZ PLANE ACTIVE

When the work plane is set to the YZ plane, the X-coordinate of the mouse is fixed and equal to zero.

Zxgrid tool tn.png CLICK TO MAKE ZX PLANE ACTIVE

When the work plane is set to the ZX plane, the Y-coordinate of the mouse is fixed and equal to zero.

Drawing a cone at three different principal (XY, YZ and ZX) work planes.

Object Snap Points & EM.Cube's Snap Modes

Every EM.Cube standard geometric object has a number of Snap Points that are strategically located on it for a variety of purposes. Snap points are very important in EM.Cube. Many CAD operations and object transformation tools work based on snap points. Each solid object in general has a number of faces, edges and vertices (or nodes).A surface object normally has one face, a number of edges and vertices. A curve usually has one edge and two or more nodes. In most EM.Cube objects, the centers of faces, the midpoints of edges and the nodes or vertices constitute the snap points of that object. For example, a Box has six face snap points, twelve edge snap points and eight vertex snap points.

When you start the EM.Cube application, it is by default in the Snap to Object mode. This means that when you move the mouse over the surface of an object (without clicking), the object becomes highlighted with a translucent shade of the selection color (yellow by default). If the object is a solid, you can see inside of the object. If you get close to a vertex, the mouse snaps to that vertex. Similarly, if you get close to the middle of an edge, the mouse snaps to the edge's midpoint. Or on a face, the mouse snaps to the center of that face. When the mouse snaps to an object's snap point, a small circle in the complementary selection color (dark blue by default) appears on the snapped point. We refer to this as a "Mouse-Over" state. At this state, the Status Bar reports the coordinates of the snapped point. If the snapped point is the center of a face, the perimeter of that face is also highlighted in the same color. If the snapped point is the midpoint of an edge, that edge is also highlighted. If you move the mouse slightly away from the snapped point, it unsnaps and starts moving freely on the work plane until it snaps again to another available snap point.

Sometimes, highlighting objects simply by mouse-over may turn out to be rather bothersome especially in dense structures. In this case, you can turn off the "Snap to Object" mode. To do so, double click on the small window at the right end of the Status Bar, which reports the current state of object snap mode. This will cycle through the different objects snap mode. Continue double clicking until you get Obj. Snap: OFF. Double clicking one more time will lead to Obj. Snap: ON. You can also enable the Snap to Object mode using the keyboard shortcut O. The illustration below depicts several objects and their corresponding snap points.

Accessing all the available snap points of an object can be quite tricky. When the mouse hovers over an object, you can more easily access the hidden snap points (those associated with the hidden faces or edges or corners) by holding down the keyboard's Ctrl Key and positioning the mouse close to the desired point.

Attention icon.png Snap to object always has priority over snap to grid. In other words, the mouse jumps from a grid node point immediately to the closest object snap point.
Various snap points of some standard geometric objects.

In addition to Snap-to-Object mode, EM.Cube provides three more snap modes:

  1. Snap to Node Mode: This mode allows you to precisely snap the cursor to any vertex or node of a given object. In other words, it snaps to singular points on the object.
  2. Snap to Edge Mode: This mode allows you to snap the cursor to all the points on any edge or along a curve object. Using the Status Bar you can read the coordinates of any point on any curve. Note that if the "Snap to Grid" is also enabled at the same time, the cursor will snap to a point along the edge or curve that has the shortest distance from closest grid point.
  3. Snap to Face Mode: This mode allows you to snap the cursor to all the points on any face or any surface object. Using the Status Bar you can read the coordinates of any point on any irregular or curved surface. Note that if the "Snap to Grid" is also enabled at the same time, the cursor will snap to a point on the face or surface that has the shortest distance from closest grid point.

The "Snap to Grid" mode is controlled independent of the other snap modes. "Snap to Object" is the default mode of EM.Cube. To switch to one of the other three snap modes, double click on the box displaying Obj Snap: ON on the Status Bar, and cycle through these modes in the order: Snap: NODE, Snap: EDGE, Snap: FACE, and Snap: OFF. The last mode completely disables any object snapping. You can enable or disable all the object snap modes from the View Menu by selecting View → Snap → Snap to Object, Snap to Node, Snap to Edge, or Snap to Face. You can check or uncheck these menu items. When there is no check mark in front of one the four snap modes, then the object snapping is disabled. From this menu, you can also enable or disable the "Snap to Grid" mode. To do so, select or deselect View → Snap → Snap to Grid.

Attention icon.png Mouse-over and highlighting objects works only in one of the four object snap modes.
Snapping to an object edge and viewing the mouse coordinates in Status Bar.

Drawing New Objects Using Other Objects' Snap Points

You can use the snap points of existing objects in the project workspace to draw new objects. This feature often turns out to be very convenient and useful. For example, you can draw a new box object out of the center of one of the six faces of another box object. Or you can draw a new rectangle strip object out of the center of one of the four edges of another rectangle strip object. To do so, select the desired drawing tool and hover the mouse over the snap point of another object where you want to place the new object. Once the existing snap point is highlighted and selected, proceed to draw the new object. The figures on the right show the procedure for drawing new objects using the snap points of existing objects.

When you draw a box, cylinder, cone or pyramid from the center of the face of another object, EM.Cube indeed establishes a temporary work plane at the selected face. The local coordinate system (LCS) of the new object is set up at the center of the selected face. When you finish the drawing process, the temporary work plane is eliminated, and the original work plane before the new drawing is re-established. When you draw a rectangle strip from an edge of another object, the edge-based drawing mode is enabled for the new rectangle strip. The "Lock Base" check box of the new rectangle strip is unchecked along the local direction normal to the selected edge.

Drawing a new box out of a face center of another box.
Drawing a new rectangle strip out of an edge center of another rectangle strip.

Setting Up Quick Standard or Non-Principal Work Planes

Setting the right work plane is very important for the following reasons:

  • Surfaces and curves are always drawn on the active work plane. As for Helix, its turns are parallel to the active work plane while its axis is normal to that plane.
  • The LCS of solid objects is drawn with local X- and Y-axes in the active work plane and the local Z-axis normal to it. This means that the bottom base of all boxes, cylinders, cones and pyramids are always drawn on the active work plane. Spheres, ellipsoids and tori are always drawn centered on the active work plane.

Oftentimes, you may simply need to set up your work plane parallel to one of the three principal planes but at an offset distance. EM.Cube provides easy shortcuts for this purpose. Hover the mouse over any object in the project workspace and highlight one of the snap points of that object. Then, type X, Y, or Z on your keyboard. This will establish a new work plane centered at the snapped point and parallel to the YZ, ZX or XY planes, respectively. You can also set up an arbitrary work plane non parallel to any of the principal coordinate planes.

Info icon.png Click here to learn how to set up an Arbitrary Work Plane.

Once a new work plane is established, the movement of your mouse will be bound to that plane. In other words, the cursor will move freely on the surface of the new work plane. The status bar now reports the "User Coordinates" of the cursor position as opposed to its "World Coordinates". The status bar also shows the word User in front of these coordinates. You can switch back to the world coordinates at any time by double-clicking on the word User, which changes it to World. Double-clicking once again toggles the state back to the user coordinates. Any object that you draw on the new work plane will have its local X- and Y-axes on this plane, and its local Z-axis normal to the plane.

Attention icon.png A new work plane will stay in effect until you switch to one of the three principal work planes.
Setting up a quick standard work plane parallel to YZ plane using the keyboard shortcut X.

Geometric Object Operations & Transformations

Changing Object Visibility, Color & Texture

You can hide and show individual objects, color groups and even the entire parts. This can be very helpful when you work with structures that contain a sizable number of parts containing large and small objects in close proximity of one another. Hiding individual objects or color groups allows you to focus on the points of interest within your structure. To hide or show individual objects or color groups or the entire parts, right-click on the name of the object, color or the "Parts" item in the navigation tree and select Hide or Show from the contextual menu.

You can also freeze individual objects or color groups. When an object is frozen, EM.Cube shows only a wireframe of that object in its own color. You cannot mouse-over, highlight or select a frozen object in the project workspace. To freeze an individual object or a color group, right-click on its name in the navigation tree and select Freeze from the contextual menu. To unfreeze a frozen object or color group, right-click on its name in the navigation tree and remove the check mark already placed before the Freeze item in the contextual menu. You can also freeze individual geometric objects using their contextual menu in the project workspace by right-clicking on their surface.

Attention icon.png You cannot highlight "frozen" objects by mouse-over.
Freezing objects in the project workspace.

You can edit an existing color from a group's property dialog. Right-click on the name of a color group on the navigation tree and select Properties... from the contextual menu. This opens up the property dialog of the selected color. You can change the default color by clicking the Color button to open up the standard color palette.

Changing the color of a color group.

By default, the color groups do not have a texture. You can replace a solid color with a texture that is generated from a bitmap image. First, you have to check the box labeled Texture. This enables the texture section of the dialog. Click the Texture button to open Windows' Open Dialog. The file type is set to "Bitmap Files (*.bmp)". Use the Browse button to find the desired bitmap file and open it. Next, you have to define the texture mapping scale. On the geometric objects, the texture will show up as tiles of the imported bitmap. In the "Texture Geometry" section of the dialog, two boxes show the Width and Height of the bitmap in pixels. You need to map these onto the desired tile width and height in project units. These settings determine how many texture tiles appear on each object given its dimensions. If large values are set for the tile width and height, partial bitmap will show up on the objects. You also have the option to apply the texture to the Side Only by checking the related box.

A bitmap image.
Setting the texture of a color group..

Selecting, Cutting, Copying, Pasting & Deleting Objects

In order to modify or apply CAD operations to objects, they must first be selected. The navigation tree provides a convenient interface that allows you to select one or more objects. The simplest way to select an object is to click on its surface in the project workspace. When an object is selected, its color changes to the "Selection Color" (yellow by default). When you select an object in the project workspace, its name on the navigation tree is highlighted in the selection color. Alternatively, you can select an object by clicking on its name in the navigation tree. In that case, the selected object's name is highlighted in the navigation tree, and the object itself is highlighted in the selection color in the project workspace. To deselect a selected object, simply click on any blank point in the project workspace.

You can select more than one object at a time. There are several ways to do a multiple selection. The simplest way is to select the first object in the project workspace. Then, while holding the keyboard's Ctrl key down, click on the second and subsequent objects that you want to add to the selection. You can follow the same procedure in the navigation tree. While holding the keyboard's Ctrl key down, click on the names of all the objects you want to select in the navigation tree. In a "Range Selection", you can select a sequential set of objects belonging to the same color group. First, you click on the name of the first object in the navigation tree. Then, while holding the keyboard's Shift key down, you click on the name of the last object to be selected. All the objects whose names are listed between those two objects are also selected and highlighted.

Cut, copy, paste and delete are some of the most common edit operations. As in many other Windows applications, you can cut an object (from the workspace) and hold it in the Windows' clipboard until you paste it back to the workspace. You can also copy an object and paste it back to the workspace. Deleting an object removes it forever from the project workspace, although you can undo your delete operation.

Selection of one or more objects (selection color is yellow).

The simplest way to cut, copy, paste o delete an object or a selection of objects is using the keyboard shortcut Ctrl+X, Ctrl+C, and Ctrl+V, respectively, or use the keyboard's Delete key. You can also use the Cut, Copy, Paste and Delete buttons of System Toolbar or similar items of the Edit Menu. The right-click contextual menu of objects in the project workspace or on the navigation tree yet provide additional ways for cutting, copying, pasting and deleting objects.

When you paste an object or a selection of objects to the project workspace, CubeCAD allows you to place the pasted object(s) in any arbitrary location right away. First, a wire-frame of the pasted object(s) appears in the workspace, which you can drag around with the mouse. Wherever in the workspace you click the mouse, the pasted object(s) will be dropped. A dialog titled "Place" appears on the lower right corner of the screen that shows the current coordinates of the mouse point (as you drag it) in three X-, Y- and Z-coordinate boxes labeled Destination as well as three X-, Y- and Z-coordinate boxes labeled Vector. The vector coordinates show the Cartesian components of the displacement vector pointing from the original position of the cut or copied object(s) to the current mouse position. As you drag the mouse around, all these values get updated continuously. You can fine-tune the final location of your pasted object using either of the two coordinate sets.

Operational Modes of CubeCAD Tools

Each of CubeCAD tools performs a certain operation or transformation on one or more selected CAD objects. EM.Cube provides a number of different ways to use these tools. First, you have to activate a CAD tool. Each tool has a button with a particular icon on Tools Toolbar, which you can click to activate. If you hover your mouse on one of these buttons before clicking, a small tooltip shows up displaying the name of that tool. You can also enable a tool from Tools Menu at the top of the screen. Many tools have a keyboard shortcut, which you simply type on your keyboard to enable that tool. You can also access some tools from the contextual menu of individual objects either by right-clicking on the surface of an object in the project workspace or by right-clicking on the object's name in the navigation tree. When you access a CAD tool from Tools Toolbar or Tools Menu, one or more Help Tips appear on the upper right corner of the screen, which guide you along the different steps of usage of the enabled tool.

The first step in using each CAD tool is to select one or more objects. When you activate a tool from Tools Toolbar or Tools Menu, a help tip prompts you to select an object by clicking on it. If the enabled tool allows the selection of more than one object (e.g. Group Tool), you can select the objects one by one and then press the Enter Key to finish the object selection. At this point, another help tip instructs you to take the next action. For most tools, alternatively, you can first select the object(s) and then activate the tool in one of the ways mentioned earlier. This is often more convenient and spares a few mouse clicks.

Working with Generic Objects

EM.Cube offers a large selection of parameterized native objects. Many of CubeCAD tools, such as translate, rotate or mirror, transform native objects to other objects of the same kind or result in the creation of other types of native objects like polylines and polystrips. Some other CAD tools result in the creation of a generic solid object, a generic surface object or a generic curve object. EM.Cube's generic objects have a limited number of parameters. They have three LCS Coordinates and three Rotation Angles, which determine their location and orientation in the project workspace. You can change these parameters by accessing the property dialog of a generic object. They also have Dimension parameters, which represent the size of the their bounding box along the three principal directions, but they are not editable. Most CAD import operations bring in external CAD files to your project workspace as generic objects.

Working with Transform Objects

Many of CubeCAD operations and transformations result in the creation of either native objects like polylines and polystrips or in generic curve, surface or solid objects. Each of the following tools, however, creates a special "Transform Object":

  1. Group Tool
  2. Array Tool
  3. Subtract Tool
  4. Union Tool
  5. Intersect Tool
  6. Extrude Tool
  7. Loft Tool
  8. Revolve Tool
  9. Polymesh Tool
  10. Random Group Tool
  11. Roughen Tool

Each transform object has a special property dialog. The Group tool and the three Boolean operation tools, Subtract, Union and Intersect, have similar property dialogs and allow you to access their constituent objects. The property dialog of composite or Boolean objects has a Member List containing the names of all constituent objects. You can highlight and select any member from this list and click the Edit button of the dialog to open up its property dialog, where you can edit its properties.

The property dialog of Extrusion, Loft, Revolution, Polymesh and Rough objects has an Edit Primitive button, which lets you access the property dialog of the original object used for the generation of the selected transform object. After you finish editing the primitive object, you will return to the property dialog of the transform object. Array and Random Group objects are arrangements of clones of an original key object. In these cases, the Edit Primitive button opens up the property dialog of the key element.

Glossary of EM.Cube CAD Tools

EM.Cube provides a large number of CAD tools that translate, rotate, scale and perform more complex geometric transformations on one or a selection of several objects.

Info icon.png To learn more about the various types of geometric object transformations and edit operations, see the Glossary of EM.Cube's CAD Tools.

Importing & Exporting External CAD Models

Importing Objects from External Files

Building complex geometries often requires the import of external CAD models. Currently, EM.Cube can import the following CAD file formats:

  1. STEP File (*.STEP or *.STP)
  2. IGES File (*.IGES or *.IGS)
  3. Stereolithography File (*.STL)
  4. Raw Triangles (*.RAW)
  5. Shape File (*.SHP)
  6. CUBIT Facet File (*.FACET)
  7. ASCII DXF File (*.DXF)
  8. Digital Elevation Map (DEM) File (*.DEM)
  9. Python File (*.PY)

To import an external file of one of the above formats, select the menu item File → Import... Once the standard Windows "Open Dialog" pops up, select the desired file extension from the drop-down list labeled "Files of Type:". Then, select the desired file and click the Open button of the dialog. This opens another dialog that shows the progress of loading the imported file. You can abort the import process by clicking the Abort Translation button. You can also view a report of the process. All imported objects are listed under "Color_1". From this group you can move them to other groups. In some cases, the imported object might already be organized in different colors or groups. In all file formats except for STL and Facet, solid objects are imported as generic solids and surface objects are imported as generic surfaces. From STL and Facet files, objects are imported as EM.Cube's native polymesh objects.

Attention icon.png You can import external CAD files only into CubeCAD, from which you can then move the imported objects to EM.Cube's other modules.
The imported STEP model of a helicopter.

Exporting Project Structure

You can save the structure that you build in EM.Cube to an external CAD file for later use or transfer to other applications. Currently, EM.Cube can export the physical structure to the following file formats:

  1. STEP File (*.STEP or *.STP)
  2. IGES File (*.IGES or *.IGS)
  3. Stereolithography File (*.STL) - ASCII
  4. Stereolithography File (*.STL) - Binary
  5. CUBIT Facet File (*.FACET)
  6. DXF File (*.DXF)
  7. Python File (*.PY)

To export the project structure to an external file of one of the above formats, select the menu item File → Export... Once the standard Windows "Save As Dialog" pops up, select the desired file extension from the drop-down list labeled "Save as type:". Then, type in a name for the file and click the Save button of the dialog. This opens another dialog that shows the progress of writing the exported file. You can abort the export process at any time by clicking the Abort Process button.

Note that in the case of DXF export, all the surface CAD objects lying in the XY Plane or in any horizontal plane and only rectangular objects lying in the YZ or ZX planes or in any vertical plane parallel to these planes are exported. Curve and solid CAD objects are ignored during the export process.

CubeCAD's Triangular Surface Mesh

Mesh generation is an important part of computational engineering. A mesh is used to discretize a continuous geometry into a set of much simpler elementary cells or "mesh elements". As you will see in EM.Cube's other modules, EM.Cube provides several mesh generators of different types. The accuracy of a numerical simulation often depends directly on the quality and resolution of the mesh.

CubeCAD provides a triangular surface mesh generator that discretizes surface objects and the surface of solid objects based on a specified edge length. The mesher algorithm generates a regularized mesh and attempts to create triangular cells of almost equal area. CubeCAD's mesh generator polygonizes curve objects based on the same edge length.

Generating and Controlling the Mesh

You can generate a mesh of the physical structure in CubeCAD in one of the following three ways:

  1. By clicking the Show Mesh Mesh tool tn.png button of the Simulate Toolbar.
  2. By selecting the menu item Simulate → Discretization → Show Mesh.
  3. Using the keyboard shortcut Ctrl+M.

When the mesh is displayed in the project workspace, EM.Cube's mesh view mode is enabled. In this mode, all the objects are discretized using CubeCAD's mesh generation algorithm and the meshes of all objects are displayed. In mesh view, you cannot mouse-over, select or edit any objects. The mesh view is for viewing purpose only. You can perform most of view operations such as zooming in and out using the mouse scroll wheel, rotating the view using the right mouse button RMB and panning the view using Shift+RMB. When EM.Cube is in mesh view mode, the Show Mesh Mesh tool tn.png button of Simulate Toolbar remains depressed. To hide the mesh, exit the mesh view mode and return to the normal view mode, simply click the Show Mesh Mesh tool tn.png button one more time to toggle its state, or press the keyboard's Esc (Escape) key, or select the menu item Simulate → Discretization → Show Mesh and remove the check mark in front of it.

CubeCAD's mesh settings dialog.

You can change the mesh type and the mesh resolution from CubeCAD's Mesh Settings dialog. Click the Mesh Settings Mesh settings tn.png button of the Simulate Toolbar or select the menu item Simulate → Discretization → Mesh Settings... In the drop-down list labeled Mesh Type you can select one of the two options: Regular Surface or Tessellated Surface. The latter option shows the simplest tessellation of the physical structure. The mesh resolution is controlled by Edge Length, which is expressed in project units. The default value of edge length is 10 units. This means that the default mesh features cells with a size of about 10 units. When you change the mesh type or resolution, you can see the effect using the Apply button if EM.Cube is already in mesh view mode. After EM.Cube generates a mesh, it saves it and uses it the next time you want to see the mesh. The mesh stays the same until you change its parameters. Sometimes, you may want to regenerate the mesh with the same current parameters. To do so, select the menu item Simulate → Discretization → Regenerate Mesh.

The geometry of two spheres.
The triangular surface mesh of the two spheres generated by CubeCAD.
The tessellated version of the two spheres.

Working with STL & FACET Models

Stereolithography (STL) files contain a tessellated (triangulated) representation of a geometrical structure. CUBIT FACET files are used to store surface mesh data. EM.Cube treats STL and FACET files in a special way. You can export the physical structure of your project workspace into a STL or FACET file in the form of polymesh objects. Your physical structure is tessellated for export using CubeCAD's triangular surface mesh generator. Therefore, you can use CubeCAD's mesher to see and examine how your physical structure is going to be exported and will look like before you export it. EM.Cube gives you two options for STL export: Binary STL and ASCII STL. The latter file is bigger in size. You can import STL files of both binary and STL types into EM.Cube. Both STL and FACET models are imported as native polymesh objects. As a result, you can edit the imported objects and modify their various parameters as you like. This is different than the import of files of other formats, which always create generic solid and surface objects. Just like other polymesh objects, you can insert nodes on the faces and edges of the imported object or delete some of its nodes. Note that some objects might be imported to CubeCAD in a freeze state, and you need to unfreeze them before being able to edit their properties.

Attention icon.png FACET files are always expressed in meters. Therefore, before importing a FACET file, you should change the project units to meters.



Top icon.png Back to the Top of the Page

Back icon.png Back to EM.Cube Main Page