Glossary of EM.Cube's Basic File, Edit & View Operations

From Emagtech Wiki
Jump to: navigation, search

Action History

ICON: None

MENU: Edit → Action History...

KEYBOARD SHORTCUT: None

FUNCTION: Opens the "Action History" dialog which lists all the actions taken since the start of the current session of the EM.Cube application

NOTES, SPECIAL CASES OR EXCEPTIONS: You can go back along the sequence of the action history list and select and highlight any action in that list. In that case, all the subsequent actions taken place after the selected action will be undone. This provides a convenient alternative to multiple Undo/Redo operations.

PYTHON COMMAND: None

EM.Cube's action history dialog.

Arbitrary Work Plane

ICON: Arbitgrid tool tn.png

MENU: View → Work Plane → Arbitrary Plane

KEYBOARD SHORTCUT: W

FUNCTION: Sets up an arbitrary active work plane

TO SET UP AN ARBITRARY WORK PLANE:

  1. Activate the Work Plane Tool to enable CubeCAD's "Work Plane Mode".
  2. The Work Plane dialog opens up at the lower right corner of the screen.
  3. Use one of the following three methods to establish a new work plane.
  4. Hover the mouse over any object in the project workspace to highlight one of its faces. Click on the selected face snap point, i.e. the center of a highlighted planar face. A new work plane appears overlaid on the selected face.
  5. Or while you are moving the mouse in one of the three principal XY, YZ or ZX work planes, click any blank point and drag the mouse. A semi-translucent plane perpendicular to the current principal work plane is drawn and displayed in the project workspace. The normal plane follows the movement of the mouse as you drag it. Once you reach the desired orientation, press the keyboard's' Enter key to finalize the new work plane.
  6. Or click successively on any three distinct points in the project workspace (including other objects' snap points). A new work plane is established that passes through the three selected points.

In all the three cases above, a translucent plane appears showing the location and orientation of the new work plane. The transverse axes (local X and Y axes) of the new work plane are displayed in red and green colors, respectively. A new "User Coordinate System (UCS)" is established on the new work plane. In the work plane dialog, you can see the world coordinates of the center of the UCS and its rotation angles with respect to the project's world coordinate system (WCS). From this dialog, you can change both the center coordinates and the rotation angles of the new work plane. Note that the visible size of the work plane is purely for visualization purposes; otherwise, the work plane has infinite extents. You can also change the Color and Transparency level of the work plane.


PYTHON COMMAND: None

EM.Cube's arbitrary work plane dialog.
An arbitrary work plane and its local X (red) and Y (green) axes.
Drawing a box object on the arbitrary work plane.

Back View

ICON: View-back tn.png

MENU: View → Set View → Back View

KEYBOARD SHORTCUT: None

FUNCTION: Projects the physical structure onto the ZX-plane from the back

PYTHON COMMAND: None

EM.Cube's back view of project workspace.

Bottom View

ICON: View-bottom tn.png

MENU: View → Set View → Bottom View

KEYBOARD SHORTCUT: None

FUNCTION: Projects the physical structure onto the XY-plane from the bottom

PYTHON COMMAND: None

EM.Cube's bottom view of project workspace.

Copy Tool

ICON: Copy.png

MENU: Edit → Copy

KEYBOARD SHORTCUT: Ctrl+C

FUNCTION: Copies the selection into the Windows clipboard

PYTHON COMMAND: None

Cut Tool

ICON: Cut.png

MENU: Edit → Cut

KEYBOARD SHORTCUT: Ctrl+X

FUNCTION: Removes the selection from the project workspace and places it in the Windows clipboard

PYTHON COMMAND: None

Delete Tool

ICON: Delete.png

MENU: Edit → Delete

KEYBOARD SHORTCUT: Delete Key

FUNCTION: Deletes the selection from the project workspace

PYTHON COMMAND: delete(node_name)

Front View

ICON: View-front tn.png

MENU: View → Set View → Front View

KEYBOARD SHORTCUT: None

FUNCTION: Projects the physical structure onto the ZX-plane from the front

PYTHON COMMAND: None

EM.Cube's front view of project workspace.

Grid Properties

ICON: None

MENU: View → Grid Properties...

KEYBOARD SHORTCUT: None

FUNCTION: Modifies the type and settings of the project workspace's grid

NOTES, SPECIAL CASES OR EXCEPTIONS: EM.Cube offers two different types of grid: Adaptive and fixed. Note that the grid is hidden by default and can be displayed from the preferences dialog. The adaptive grid is the default choice, and its grid cell size changes dynamically according the viewport size. As a result of this, during a dynamic zoom process, the grid seems to maintain almost the same size even though your physical structure looks bigger or smaller depending on whether you zoom in or zoom out. The fixed grid, on the other hand, always maintains fixed dimensions and a fixed grid cell size. Therefore, the fixed grid grows or shrinks along with your physical structure due to a dynamic zoom operation. With a fixed grid, you can set different grid cell dimensions along the three principal axes.

PYTHON COMMAND: None

EM.Cube's Grid Settings dialog.
EM.Cube's adaptive grid.
EM.Cube's fixed grid.

Help

ICON: Help.png

MENU: Help → View Online Help

KEYBOARD SHORTCUT: Ctrl+Shift+H

FUNCTION: Opens online EM.Cube documentation in your browser

PYTHON COMMAND: None

Left View

ICON: View-left tn.png

MENU: View → Set View → Left View

KEYBOARD SHORTCUT: None

FUNCTION: Projects the physical structure onto the YZ-plane from the left

PYTHON COMMAND: None

EM.Cube's left view of project workspace.

Merge Viewport

ICON: Single-port-view tn.png

MENU: View → Merge Viewport

KEYBOARD SHORTCUT: End Key

FUNCTION: Merges the four-port view into the normal single-port view

PYTHON COMMAND: None

New Project

ICON: New.png

MENU: File → New Project...

KEYBOARD SHORTCUT: Ctrl+N

FUNCTION: Starts a new blank EM.Cube project

PYTHON COMMAND: None

EM.Cube's New Project Dialog.

Open Project

ICON: Open.png

MENU: File → Open Project...

KEYBOARD SHORTCUT: Ctrl+O

FUNCTION: Opens an existing EM.Cube project

PYTHON COMMAND: None

Pan View Tool

ICON: Pan-tool tn.png

MENU: View → Pan View

KEYBOARD SHORTCUT: Shift+RMB

FUNCTION: Moves the viewport around while the mouse is dragged

PYTHON COMMAND: None

Paste Tool

ICON: Paste.png

MENU: Edit → Paste

KEYBOARD SHORTCUT: Ctrl+V

FUNCTION: Places the contents of the Windows clipboard on the project workspace

PYTHON COMMAND: None

Perspective View

ICON: View-perspective tn.png

MENU: View → Set View → Perspective View

KEYBOARD SHORTCUT: Home Key

FUNCTION: Sets an isometric view of the physical structure on an XY-plane

PYTHON COMMAND: None

EM.Cube's perspective view of project workspace.

Print

ICON: Print.png

MENU: File → Print...

KEYBOARD SHORTCUT: Ctrl+P

FUNCTION: Prints the contents of the main window on the specified printer

PYTHON COMMAND: None

Redo Tool

ICON: Redo.png

MENU: Edit → Redo

KEYBOARD SHORTCUT: Ctrl+Y

FUNCTION: Redoes the last operation

PYTHON COMMAND: None

Restore Program Defaults

ICON: None

MENU: File → Restore Program Defaults

KEYBOARD SHORTCUT: None

FUNCTION: Restores the original black background and yellow selection color and turns off the project workspace's grid

PYTHON COMMAND: None

Right View

ICON: View-right tn.png

MENU: View → Set View → Right View

KEYBOARD SHORTCUT: None

FUNCTION: Projects the physical structure onto the YZ-plane from the right

PYTHON COMMAND: None

EM.Cube's right view of project workspace.

Rotate View Tool

ICON: Rotate-tool tn.png

MENU: View → Rotate View

KEYBOARD SHORTCUT: RMB or Alt+RMB

FUNCTION: Rotates the viewport about the origin of the world coordinate system (WCS) while the mouse is dragged

NOTES, SPECIAL CASES OR EXCEPTIONS: Using the right mouse button ( RMB) for rotating the view is a temporary operation and it doesn't change EM.Cube's view mode. Clicking on the "Rotate View" button of the View Toolbar changes EM.Cube's view mode to the "Rotate View Mode". In this mode, you can drag the mouse using either of the left or right mouse buttons to rotate the view about different axes. Also note that the axis of rotation in the case of rotate view mode is different than the axis of rotation using the temporary RMB or Alt+RMB shortcuts.

PYTHON COMMAND: None

Save Project

ICON: Save.png

MENU: File → Save Project...

KEYBOARD SHORTCUT: Ctrl+S

FUNCTION: Saves the current EM.Cube project

PYTHON COMMAND: None

Save Project As

ICON: Save.png

MENU: File → Save Project As...

KEYBOARD SHORTCUT: Ctrl+W

FUNCTION: Saves the current EM.Cube project under a different name

PYTHON COMMAND: None

Select Tool

ICON: Select-tool tn.png

MENU: View → Normal View

KEYBOARD SHORTCUT: Esc Key

FUNCTION: Returns to the normal select mode

PYTHON COMMAND: None

Snap to Edge

ICON: None

MENU: View → Snap → Snap to Edge

KEYBOARD SHORTCUT: E

FUNCTION: Toggles the "Snap-to-Edge" mode. In this mode, the mouse snaps to a point on the nearest object edge. Both the edge and the point on it are highlighted. You can move the mouse incrementally and locally on the highlighted edge. This mode is particularly useful for CAD operations that require selecting an object edge such as extruding, lofting or revolving an edge or bridging between two edges.

PYTHON COMMAND: None

Snap to Face

ICON: None

MENU: View → Snap → Snap to Face

KEYBOARD SHORTCUT: F

FUNCTION: Toggles the "Snap-to-Face" mode. In this mode, the mouse snaps to a point on the nearest object face. Both the face and the point on it are highlighted. You can move the mouse incrementally and locally on the surface of the highlighted face. This mode is particularly useful for CAD operations that require selecting an object face such as extruding, lofting or revolving a face or skinning between two faces.

PYTHON COMMAND: None

Snap to Grid

ICON: None

MENU: View → Snap → Snap to Grid

KEYBOARD SHORTCUT: G

FUNCTION: Toggles the "Snap-to-Grid" mode. In this mode, the mouse snaps to a point on the project workspace's grid. In that case, a small white (round or square) point appears on the screen beside the normal arrow cursor that shows the current location of the mouse in the project workspace. EM.Cube's snap-to-grid mode is enabled by default. Note that you can enable the snap-to-grid mode without having to display the grid on the screen.

PYTHON COMMAND: None

Snap to Node

ICON: None

MENU: View → Snap → Snap to Node

KEYBOARD SHORTCUT: N

FUNCTION: Toggles the "Snap-to-Node" mode. In this mode, the mouse snaps to the nearest object snap point. However, only a node, vertex or point is highlighted.

PYTHON COMMAND: None

Snap to Object

ICON: None

MENU: View → Snap → Snap to Object

KEYBOARD SHORTCUT: O

FUNCTION: Toggles the "Snap-to-Object" mode. In this mode, the mouse snaps to the nearest object snap point. If the snap point is the midpoint of an edge, the edge is also highlighted. If the snap point is the center of a face, the fact is also highlighted. EM.Cube's snap-to-object mode is enabled by default.

PYTHON COMMAND: None

Split Viewport

ICON: Four-port-view tn.png

MENU: View → Split Viewport

KEYBOARD SHORTCUT: None

FUNCTION: Displays a four-port view of the project workspace

NOTES, SPECIAL CASES OR EXCEPTIONS: Splitting the viewport provides simultaneous Perspective, Top, Front and Right views in the Project Workspace. Each split viewport’s settings can be changed individually. The name of the active viewport on which changes apply is always highlighted with a dark blue background; inactive views are indicated by a gray background. In the Four-Port View mode, you can zoom, extents or rotate the view for each viewport individually.

PYTHON COMMAND: None

EM.Cube's four-port view of project workspace.

Toggle Navigation Tree

ICON: Navtree.png

MENU: View → Navigation Tree

KEYBOARD SHORTCUT: None

FUNCTION: Toggles the visibility of the navigation tree window

PYTHON COMMAND: None

Top View

ICON: View-top tn.png

MENU: View → Set View → Top View

KEYBOARD SHORTCUT: None

FUNCTION: Projects the physical structure onto the XY-plane from the top

PYTHON COMMAND: None

EM.Cube's top view of project workspace.

Undo Tool

ICON: Undo.png

MENU: Edit → Undo

KEYBOARD SHORTCUT: Ctrl+Z

FUNCTION: Undoes the last operation

PYTHON COMMAND: None

Undo View Change / Redo View Change

ICON: Undo-view-change tn.png

MENU: View → Undo View Change, View → Redo View Change

KEYBOARD SHORTCUT: None

FUNCTION: Reverts the viewport to the previous view angle and distance

PYTHON COMMAND: None

User Preferences

ICON: None

MENU: Edit → Preferences...

KEYBOARD SHORTCUT: Ctrl+H

FUNCTION: Opens the "User Preferences" dialog from which you can control a number of permanent project settings

PYTHON COMMAND: None

The "Colors" tab of the user preferences dialog.
The "Objects" tab of the user preferences dialog.
The "Guides" tab of the user preferences dialog.
The "Spin Buttons" tab of the user preferences dialog.
The "Advanced" tab of the user preferences dialog.

Viewport Properties

ICON: None

MENU: View → Viewport Properties...

KEYBOARD SHORTCUT: None

FUNCTION: Modifies the default settings of the viewport

NOTES, SPECIAL CASES OR EXCEPTIONS: This dialog is used to set the size and boundaries of the viewport manually. You can set the viewport size by specifying the coordinates of the "Top-Left-Near" and "Bottom-Right-Far" points. You can also set the coordinates of the viewing camera location.

PYTHON COMMAND: None

EM.Cube's Viewport Settings dialog.

Workspace Screen Capture

ICON: None

MENU: File → Workspace Screen Capture

KEYBOARD SHORTCUT: None

FUNCTION: Creates a bitmap image of a screenshot the project workspace

NOTES, SPECIAL CASES OR EXCEPTIONS: The bitmap screenshot is stored in the "images" subfolder of the current project folder. It is listed under the "Image Files" tab of the data manager.

PYTHON COMMAND: None

XY Plane

ICON: Xygrid tool tn.png

MENU: View → Work Plane → XY Plane

KEYBOARD SHORTCUT: Z

FUNCTION: Makes the principal XY plane the active work plane

PYTHON COMMAND: None

EM.Cube's perspective view of project workspace with active XY work plane and enabled grid.

YZ Plane

ICON: Yzgrid tool tn.png

MENU: View → Work Plane → YZ Plane

KEYBOARD SHORTCUT: X

FUNCTION: Makes the principal YZ plane the active work plane

PYTHON COMMAND: None

EM.Cube's perspective view of project workspace with active YZ work plane and enabled grid.

Zoom Tool

ICON: Zoom-tool tn.png

MENU: View → Zoom → Dynamic

KEYBOARD SHORTCUT: Ctrl+RMB or Mouse Scroll Wheel

FUNCTION: Zooms into or out of the project workspace while the mouse is dragged up or down, respectively

PYTHON COMMAND: None

Zoom To Extents Tool I

ICON: Zoom-to-extent tn.png

MENU: View → Zoom → Extents

KEYBOARD SHORTCUT: Ctrl+E

FUNCTION: Automatically zooms to fit the whole physical structure into the main window

PYTHON COMMAND: zoom_extents()

Zoom To Extents Tool II

ICON: Zoom-to-extent tn.png (right-click)

MENU: View → Zoom → Extents All

KEYBOARD SHORTCUT: Ctrl+Shift+E

FUNCTION: Automatically zooms to fit the whole physical structure into all four viewports in the four-port view mode

PYTHON COMMAND: None

Zoom To Selected Tool

ICON: Zoom-to-selected tn.png

MENU: View → Zoom → Selected

KEYBOARD SHORTCUT: None

FUNCTION: Automatically zooms to fit the highlighted object into the main window

PYTHON COMMAND: None

Zoom Window Tool

ICON: Zoom-to-area tn.png

MENU: View → Zoom → Window

KEYBOARD SHORTCUT: None

FUNCTION: Draws a window to define the zoom boundaries

PYTHON COMMAND: None

ZX Plane

ICON: Zxgrid tool tn.png

MENU: View → Work Plane → ZX Plane

KEYBOARD SHORTCUT: Y

FUNCTION: Makes the principal ZX plane the active work plane

PYTHON COMMAND: None

EM.Cube's perspective view of project workspace with active ZX work plane and enabled grid.



Top icon.png Back to the Top of the Page

Back icon.png Back to Getting Started with EM.Cube

Back icon.png Back to CubeCAD Page

Back icon.png Back to EM.Cube Main Page