Navigating the Visual Interface: Workshop & Toolbox

From Emagtech Wiki
Revision as of 14:10, 10 November 2016 by Kazem Sabet (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Rfspice banner.png

Back icon.png Back to RF.Spice A/D Wiki Gateway

Tutorial icon.png RF.Spice A/D Tutorial Gateway

An Overview of RF.Spice A/D Workshop

RF.Spice A/D allows you to enter a circuit design in its Schematic Editor, run simulations of your circuit using its SPICE engine(s), and view the simulation results in its data manager. All this is done in the RF.Spice A/D Workshop. To open the Workshop, double-click the RF.Spice A/D icon on your desktop. When you start the application, a blank circuit appears in the Main Window. This is the Schematic Editor window, where you define and place your parts, connect them using wires and build up your circuit.

Besides the schematic editor occupying the main window, the RF.Spice A/D Workshop consists of a number of other visual elements:

The RF.Spice A/D Workshop

Working with Toolbox

One of the important visual elements of RF.Spice A/D is its Toolbox located on its left side panel. The Toolbox allows you quick access and navigation to all your project properties, parts in the current project, parts in your custom palette, and all the parts in the database. It also contains the Test Panel and all the graph settings and controls. From the toolbox, you can quickly select parts, set various parameters for the analysis of your circuit and customize your output data and graphs.

RF.Spice's Toolbox has a number of tabs:

  • Edit Plots (Only when a graph window is active)
  • Edit Graph (Only when a graph window is active)
  • Tracker (Only when a graph window is active)
  • Edit Axes (Only when a graph window is active)

Parts Bin

Besides RF.Spice's standard database browser where you can search a part by name or filter by category or keyword, the Parts Bin of the toolbox allows you to pick and place the exact part you want by function, manufacturer or name from a pop-up menu. Clicking on the "Parts Bin" tab allows you to scroll through a parts list grouped by function, or by manufacturer or by name. "Parts Palette" allows you to store your most frequently used parts available in your company's inventory for quick and easy access. You can add and remove parts as your requirements change.

The first time you select a part, the program will seem to hang, but it is indeed pulling data from the parts database. This might take a few seconds and is completely normal. More importantly, this will only happen the FIRST time you select a part. Once the program fills in the data, subsequent device selections will take place without a pause.

Info icon.png For further discussion of how to choose and place parts, please see the section on Choosing and Placing Parts.

Circuit Parameters

The Parameters tab of the toolbox contains a list of all the parts in your circuit whose parameters can be changed, such as resistors, capacitors, etc. Next to each part is its current value. The purpose of this area is to allow quick changes of part values while a live simulation is running.

Info icon.png To learn more about RF.Spice's live parameters, please refer to the section on Circuit Parameters.

The RF.Spice A/D Parts Bin and the Toolbox tabs on the left side panel.
The RF.Spice A/D Circuit Parameters tab.

Circuit Tests

In RF.Spice A/D, "Predefined Tests" and "Live Simulations" are now two distinct simulation modes. Live simulations refer to perpetual time-domain simulations that start at t = 0 and end only when you pause or reset them. Tests are pre-defined analysis types that you run on your circuit to see how it behaves under various domains. DC Bias (Operating Point), AC, Transient are some examples of test types you will frequently run in RF.Spice A/D. Each test can be selected, set up, and run from the pull down menu in the Tests tab of the toolbox. Unlike live simulations, tests are NOT interactive, and the results are displayed on a graph or in a table, NOT on virtual instruments.

Info icon.png For detailed descriptions on each Test, refer to the section on Analyzing Circuits Using Predefined Tests.

Project Management Using Workspace

The Workspace tab of the toolbox allows you total control over the all the files associated with a circuit. The workspace is set up in a collapsible tree-based structure. Each project can be expanded to show all the files associated with that project, including the circuit itself, the simulations, simulation results, and associated graphs. You can add new files or close existing files in the workspace by highlighting the project or file, opening the File Menu and choosing the appropriate command.

The RF.Spice A/D Test Panel.
The RF.Spice A/D Project Workspace.

Circuit Animation

Circuit Animation allows graphical and text representation of the circuit state on the schematic using wire/part colors as well as symbols and text to represent the voltage, current and power states of the circuit while a live simulation is running. More details about live data visualization can be found in the section on Circuit Animation.

Circuit Wizards

The idea behind the Circuit Wizards is easy circuit creation. Just select the type of circuit that you wish to create, fill in a few choices and the rest of the work is done for you. You may select to place the new circuit directly into your existing circuit or place it into a blank circuit to start a new design.

RF.Spice A/D Circuit Wizard - Main Page
RF.Spice A/D Circuit Wizard - Filter Design

Graphing and Plot Controls

When a graph window is active, the toolbox contains four additional tabs: "Edit Graph", "Edit Axes", "Tracker" and "Edit Plots". All aspects of the graph are controlled from these tabs. The Edit Graph tab controls the appearance of the graph itself, including the graph size, color and text on the graph, as well as the plot colors. The Tracker tab allows you to view the various plots on the graph and information relevant to the plots. From the Edit Axes tab, you can adjust the individual axes, their bounds and appearance. The Edit Plots tab controls the individual plots in the graph and how they appear. Here you can add and remove plots from the graph as well as making custom plots using a built-in function library.

Info icon.png To learn more about graphs and plotting data in RF.Spice A/D, see the section on Visualizing Simulation Data Using Graphs and Tables.

RF.Spice A/D Edit Graph Tab
RF.Spice A/D Edit Axes Tab
RF.Spice A/D Edit Plots Tab

Toolbars, Menus & Windows

RF.Spice A/D is mainly controlled by the Toolbox and Toolbars. Toolbars are collections of icons that are shortcuts to menu commands, and are located below the menus. RF.Spice A/D has a Main Toolbar which is common to all modes of operation and is used to control file and simulation functions. It also has two other window-specific toolbars to control other functions available for specific windows. Schematic Toolbar appears only when a schematic is the active window. Graph Toolbar appears only when a graph is the active window. For a more information on each toolbar, follow these links:

RF.Spice A/D Main Toolbar
RF.Spice A/D Schematic Toolbar
RF.Spice A/D Graph Toolbar

Another important visual element of RF.Spice A/D is its menu bar located at the top of the screen underneath the title bar. Menus provide another convenient way to access many different functions such as file and edit operations, view settings, simulation, as well as a large number of generic parts passive and active elements, digital parts and virtual blocks. The contents of the menu bar changes depending on the active window:

RF.Spice A/D Schematic Menu
RF.Spice A/D Graph and Table Menus

RF.Spice A/D has changed the way windows are arranged and appear. The biggest difference is that now all windows are "tabs" in a larger Project window. Projects contain all the files associated with a particular circuit, including any graphs, netlists, and other related files. All Project files will appear in one window with the different Project files as Tab at the bottom left of the window. If you load a new circuit, it will automatically open in a new Project Window. More than one Project can be open at once. To switch to a different view, just click on the Tab that you wish to view. If you right click on a window tab, you will get the contextual pop-up menu, from which you can choose to close the Tab, add a new Tab, or rename the Tab.

For more specific information on each type of window, refer to the specific windows section below.

The Project window can be arranged so that the Tabs are displayed side by side or one atop another. To do so select the layout you wish from the Layout button in the toolbar. Any layout chosen will arrange the Tab windows as indicated by the icon in the menu only for that project. If there are not enough tabs to split as chosen by the Layout button, the program will leave that pane empty. You can then fill it up with new tabs that you create. You can also drag existing windows to the empty frames. To move windows, drag the window tab to the window that you wish to move the existing window to.

RF.Spice A/D Schematic Window
RF.Spice A/D Graph Window
RF.Spice A/D Table Window
RF.Spice A/D Text Window

Info icon.png To learn more about building schematics in RF.Spice A/D, see the section on Working with Schematic Editor.

Info icon.png To learn more about graphs and data tables in RF.Spice A/D, see the section on Visualizing Simulation Data Using Graphs and Tables.

Virtual Instruments

A very useful and important feature of RF.Spice A/D is the Virtual Instruments. Now you have ten instruments to manipulate and measure your circuit. Click on each instrument below to see a detailed description of it.

RF.Spice A/D Virtual Instrument Panel

The specific parameters of each instrument are set using its "setup" button. Pressing the “Setup” button toggles the size of the virtual instrument window. Most instruments have two or more tabs in their settings section containing a number of parameters that can be adjusted. When the setup is complete, press the "Setup" button once again to make the instrument only as tall as its title bar.


Tutorial icon.png RF.Spice A/D Tutorial Gateway

Back icon.png Back to RF.Spice A/D Wiki Gateway