EM.Terrano Tutorial Lesson 10: Modeling A Mobile Communications Link

From Emagtech Wiki
Jump to: navigation, search
Tutorial Project: Modeling A Mobile Communications Link
Terrano L10N Fig title.png

Objective: In this project, you will simulate a mobile transmitter and receiver in the Ann Arbor propagation scene.

Concepts/Features:

  • Variables
  • Parametric Sweep
  • Received Power Coverage Map
  • Plot Animation

Minimum Version Required: All versions

'Download2x.png Download Link: EMTerrano_Lesson10

What You Will Learn

In this tutorial lesson, you will use EM.Cube's Mobile Path capability. You will use Mobile Path Wizards to model a mobile path in the Downtown Ann Arbor propagation scene.

Back icon.png Back to EM.Terrano Manual

Back icon.png Back to EM.Terrano Tutorial Gateway

Download2x.png Download projects related to this tutorial lesson

Getting Started

Open the EM.Cube application and switch to EM.Terrano. For this tutorial lesson, you will use the same Downtown Ann Arbor scene you created in the previous tutorial lessons. Follow the same instructions in the section titled "Constructing the Downtown Ann Arbor Scene" of Tutorial Lesson 7. Alternatively, you can download the "Ann Arbor Template" project using this link. Set the center frequency of the project to 5.8GHz. The table below summarizes the project parameters:

Starting Parameters
Name EMTerrano_Lesson10
Length Units Meters
Frequency Units GHz
Center Frequency 5.8GHz
Bandwidth 1GHz

Using Polyline Tool to Draw the Mobile Path

You want to move your transmitter around the city and see how the coverage map is affected due to the multipath effects. Use Polyline Tool to draw the transmitter mobile path. Since the height of the transmitter will stay fixed (vehicle-mounted), you will need to define the X and Y coordinates of the transmitter's location at each step or instant of time. The Figure below shows the mobile path of the transmitter across the scene. It consists of three segments:

  1. Lower horizontal segment between (600, 160, 2.5) and (200, 160, 2.5) with 30m steps along the -X axis
  2. Vertical segment between (200, 160, 2.5) and (200, 560, 2.5) with 30m steps along the +Y axis
  3. Upper horizontal segment between (200, 560, 2.5) and (600, 560, 2.5) with 30m steps along the +X axis
The mobile path of the transmitter across downtown Ann Arbor.

Define a virtual object group that will be invisible to the simulation engine. Virtual materials have only one property, which is their color. Right-click on the Virtual Objects item in the navigation tree. Then select Insert a Virtual Material... to open up the Virtual Material dialog. Click the OK button of the dialog to return to the project workspace. To draw a polyline, click the Polyline Polyline tool tn.png button of the Object Toolbar or select the menu item Object → Curve → Polyline.

Selecting the Polyline tool in the object toolbar.

Activate the Polyline Tool. Click at point (600m, 160m, 2.5m) on the active work plane to create nodes. The polyline's contour is rendered as soon as the second node is defined. Create 9 nodes with 30m steps along the -X axis and 8 nodes with 30m steps along the +Y axis and 8 nodes with 30m steps along the +X axis. You can finish the drawing either by double-clicking on the last node or first creating the last node and pressing the keyboard's Enter key. The polyline can be closed at any time using the keyboard shortcut C. This connects the last drawn node to the first.

Drawing a polyline.

The property dialog of a polyline object lists the individual nodes and their coordinates ordered by the node ID. You can select and highlight each node and change its coordinates using the Edit button of the dialog. You can also delete each node using the Delete key or insert a new node between the selected node and its next node using the Insert key. The new node is placed at the midpoint between the selected node and the node having the next ID number.

The property dialog of a polyline object lists the individual nodes and their coordinates.

Defining the Transmitter and Receiver Sets

You will use the Mobile Path Wizard tool to create a mobile path of transmitters along the virtual polyline object “Polyline_1”. Click on the Mobile Path Wizard Mobile Path icon.png button of the Wizard Toolbar or select the menu item Tools → Propagation Wizards &rarr Mobile Path. A Mobile Path Wizard dialog pops up. You can change the label to “Tx”, choose Transmitter Set option, and select “Polyline_1” from the “Existing Nodal Curve” as a source for point data. Accept the changes and click the OK button to close the dialog. The transmitter height of 2.5m corresponds to a vehicle-mounted antenna.

Selecting the mobile path wizard on EM.Terrano's wizard toolbar.
The dialog of the mobile path wizard.
The mobile path of the transmitter across downtown Ann Arbor.

For the receiver set, you will define a point radiator called "Rx" with the color orange. Under "Rx", create an array of base points for receiver set according to the tables below:

Part Object Type Object Group Group Color Coordinates
Point_1 Point Rx Orange (0m, 0m, 1.5m)
Array Object Parent Object X Count Y Count Z Count X Spacing Y Spacing Z Spacing
Array_1 Point_1 86 77 1 10m 10m 0

Your Ann Arbor scene should look like the figure the below:

The Ann Arbor scene propagation scene after establishing the transmitter and receiver array.

Running a Transmitter Sweep

In this section, you will run a transmitter sweep of your propagation scene. When your propagation scene contains two or more transmitters, whether they all belong to the same transmitter set with the same radiation pattern or to different transmitter sets, EM.Terrano assumes all to be coherent with respect to one another. In other words, synchronous transmitters are always assumed. The rays originating from all these transmitters are superposed coherently and vectorially at each receiver. In a transmitter sweep, on the other hand, EM.Terrano assumes only one transmitter broadcasting at a time. The result of the sweep simulation is a number of received power coverage maps, each corresponding to a transmitter in the scene.

Keep in mind that transmitter sweep works only with Polarimatrix solver and requires an existing ray database. Run an SBR channel analysis of your propagation scene with a simulation of the "Single-Frequency Analysis" option to generate "sbr_channel_matrix.DAT" data file. Next, open the Run Dialog and select Communication Link Solver (Polarimatrix) from the "Select Simulation or Solver Type Mode" drop-down list and choose Transmitter Sweep (COMM Link Solver only) for the“Simulation Mode”. Start the sweep and wait until all the 20 individual simulations are completed. Then, visualize the coverage map and animate it.

EM.Terrano's simulation run dialog showing Transmitter Sweep selected as the simulation mode.
The receive power coverage map of the Ann Arbor scene corresponding to the first position of the mobile transmitter.
The receive power coverage map of the Ann Arbor scene corresponding to the 5th position of the mobile transmitter.
The receive power coverage map of the Ann Arbor scene corresponding to the 12th position of the mobile transmitter.
The receive power coverage map of the Ann Arbor scene corresponding to the 17th position of the mobile transmitter.
The receive power coverage map of the Ann Arbor scene corresponding to the 22th position of the mobile transmitter.
The receive power coverage map of the Ann Arbor scene corresponding to the last (25th) position of the mobile transmitter.

Animating Your Coverage Maps

You can animate the coverage map plots in the project workspace. Right-click on the name of the receiver set "RX1" in the navigation tree and select Animation from the contextual menu. The 25 coverage maps start to appear in the project workspace consecutively and in an infinite loop. The Animation Controls dialog pops up at the lower right corner of the screen. From this dialog you can modify the animation frame rate in milliseconds. Use the Esc key to stop the animation.

The animation controls dialog.
VIDEO: Animation of top view of the coverage map of the Ann Arbor scene corresponding to the last position of the mobile transmitter (polymeshed buildings).

In order to have a better view, you may consolidate the polymesh "Default" object to generic solid object using the Consolidate Tool. Activate the Consolidate Tool by clicking the Consolidate Consolidate tool tn.png button of the Tools Toolbar or select the menu item Tools → Transform → Consolidate. Click on the polymesh "Default" object and press the Enter Key when done. Generic surface of solid versions of "Default" object appears in the project workspace. Now animate the coverage map plots in the project workspace.

VIDEO: Animation of top view of the coverage map of the Ann Arbor scene corresponding to the last position of the mobile transmitter.

Running a Mobile Sweep

In the last part of this tutorial lesson, you will perform a mobile sweep simulation of your propagation scene. In a mobile sweep, each transmitter is paired with a receiver according to their indices in their parent sets. At each simulation run, only one (Tx, Rx) pair is considered to be active in the scene. As a result, the generated coverage map takes a different meaning implying the sequential movement of the transmitter and receiver pair along their corresponding paths. In other words, the set of point transmitters and the set of point receivers indeed represent the locations of a single transmitter and a single receiver at different instants of time. It is obvious that the total number of transmitters and total number of receivers in the scene must be equal. Otherwise, EM.Terrano will prompt an error message.

Use Polyline Tool to draw the virtual polyline object “Polyline_1” consist of

(200m, 160m, 2.5m),
(200m, 360m, 2.5m),
(200m, 560m, 2.5m),
(400m, 560m, 2.5m), and
(600m, 560m, 2.5m).

Repeat the procedure for the virtual polyline object “Polyline_2” that encompass

(500m, 190m, 1.5m),
(550m, 190m, 1.5m),
(600m, 190m, 1.5m),
(600m, 240m, 1.5m), and
(600m, 290m, 1.5m).

Then, use the Mobile Path Wizard tool to create a mobile path of transmitters along the virtual polyline object “Polyline_1”. Next, create a mobile path of receivers along a new virtual polyline object “Polyline_2”. Click on the Mobile Path Wizard Mobile Path icon.png button of the Wizard Toolbar or select the menu item Tools → Propagation Wizards &rarr Mobile Path. A Mobile Path Wizard dialog pops up. You can change the label to “Rx”, choose Receiver Set option, and select “Polyline_2” from the “Existing Nodal Curve” as a source for point data. Accept the changes and click the OK button to close the dialog.

The dialog of the mobile path wizard.
The mobile path of the transmitters and receivers across downtown Ann Arbor.
The top view of the mobile path of the transmitters and receivers across downtown Ann Arbor.

Note that mobile sweep works only with Polarimatrix solver and requires an existing ray database. First, run an SBR channel analysis of your propagation scene with a simulation of the "Single-Frequency Analysis". Next, open the Run Dialog and select Communication Link Solver (Polarimatrix) from the "Select Simulation or Solver Type Mode" drop-down list and choose Mobile Sweep (COMM Link Solver only) for the “Simulation Mode”. Run the sweep and visualize the coverage map.

EM.Terrano's simulation run dialog showing Mobile Sweep selected as the simulation mode.
The receive power coverage map of the Ann Arbor scene.




Top icon.png Back to the Top of the Page

Back icon.png Back to EM.Terrano Tutorial Gateway